Bài viết này, tôi sẽ hướng dẫn các bước cấu hình VPN theo giao thức PPTP trên thiết bị router của hãng Mikrotik.

Sử dụng phần mềm WinBox của Mikrotik để truy cập giao diện cấu hình của thiết bị. Cung cấp đầy đủ các trường thông tin bao gồm: IP, Login (username)Password sau đó nhấn nút Connect để vào giao diện quản lý của router.

PPTP-vpn-mikrotik-step1

Sau khi đã vào được giao diện quản trị của router Mikrotik, tìm tới IP -> Pool để khởi tạo dãy IP cấp phát cho người dùng VPN.

PPTP-vpn-mikrotik-step2

Trong cửa sổ IP Pool mới mở ra, bấm vào dấu “+” để tạo thêm lớp mạng.

PPTP-vpn-mikrotik-step3

Tiếp tục, bấm vào PPP để mở cửa sổ quản lý PPP. Tại đây, bấm vào thẻ Interface và tìm nút PPTP Server. Mở cửa sổ PPTP Server lên và chọn vào Enabled, đồng thời đánh dấu chọn cho  2 mục mschap2mschap1.

PPTP-vpn-mikrotik-step4

Tiếp tục, vẫn ở trong cửa sổ PPP, di chuyển qua thẻ Secrets, chọn vào dấu “+” để tạo tài khoản đăng nhập VPN mới.

PPTP-vpn-mikrotik-step5

Bước tiếp theo là mở port cho dịch vụ VPN. Ta vào IP -> Firewall và chọn và thẻ Filter Rules. Ở đây, tạo mới 1 rule với Chain là “input”, Protocol chọn 6 (tcp)Dst. Port thì nhập vào 1723.

PPTP-vpn-mikrotik-step6

Tương tự như vậy, tạo thêm 1 Filter Rues với Protocol 47 (gre) là xong.

PPTP-vpn-mikrotik-step7

Tiếp tục, di chuyển qua thẻ NAT và tiến hành NAT cho lớp mạng của VPN.

Thiết lập Chain là srcnat, Src. Address là lớp mạng vpn đã tạo ở ban đầu.

PPTP-vpn-mikrotik-step8

Trong thẻ Action, chọn Action: là masquerade và nhấn OK để kết thúc tạo rule NAT.

PPTP-vpn-mikrotik-step9

Sử dụng dịch vụ quản lý VPN mặc định của Windows, tạo luồng kết nối mới với các thông tin đã khởi tạo ở trên. Server name or address thì nhập vào IP Public của mạng đang cấu hình.

Lưu ý: VPN type phải chọn Point to Point Tunneling Protocol (PPTP).

PPTP-vpn-mikrotik-step10

Một cách khác nhanh hơn là sử dụng dòng lệnh của Mikrotik:

Bước 1: Tạo IP Pool

/ip pool

add name=vpn ranges=192.168.89.2-192.168.89.255

Bước 2: Thiết lập PPP Profile

/ppp profile

set *FFFFFFFE local-address=192.168.89.1 remote-address=vpn

Bước 3: Kích hoạt PPTP Server 

/interface pptp-server server

set enabled=yes

Bước 4: Tạo Filter Rules trong IP -> Firewall

/ip firewall filter

add action=accept chain=input dst-port=1723 protocol=tcp

add action=accept chain=input protocol=gre

Bước 5: Tạo rule NAT trong IP -> Firewall

/ip firewall nat

add action=masquerade chain=srcnat comment=”masq. vpn traffic” src-address=192.168.89.0/24

Bước 6: Thiết lập tài khoản để kết nối VPN

/ppp secret

add name=thuong password=<mật_khẩu_của_bạn>

Chúc bạn thành công!

VÕ TÌNH THƯƠNG

votinhthuong9@gmail.com